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S7-GRAPH

S7-GRAPH S7-GRAPH S7-GRAPH

Windows ->Simatic->Documentation->English

“S7-GRAPH - Programming Sequential Control Systems” PDF 15

S7-GRAPH S7-GRAPH  

S7-GRAPH

S7-GRAPH

S7-GRAPH

 

S7-300 S7- 400  (LAD)  
http://support.automation.siemens.com/CN/view/zh/18654395 
S7-300 S7-400  (STL)  
http://support.automation.siemens.com/CN/view/zh/18653496 

STEP 7 V5.3  
http://support.automation.siemens.com/CN/view/zh/18652056 
S7-GRAPH V5.3 for S7-300/400  
http://support.automation.siemens.com/CN/view/zh/1137630 

2.

2.1. S7-GRAPH
S7-GRAPH  

  

 IEC 61131-3 

 PLCopen  

  SIMATIC S7-300 ( CPU314 CPU), S7-400, C7 and WinAC 

S7-GRAPH PLC
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 250  

 250  

 32  

 32  

  

  

2.2. S7-GRAPH STL  

S7-GRAPH STL, STL 

 

2.3. S7-GRAPH  

STEP7 S7-GRAPH STEP7 Professional 

S7-GRAPH S7 S7-GRAPH STEP7

S7-GRAPH  

2.4. S7-GRAPH   

S7-GRAPH STEP7  X -  

 
2-1 S7-GRAPH  

S7-GRAPH V5.3+SP1  

2.5. S7-GRAPH  

 

 Sequencer       

 Step     

 Branch     

 Interlock    

 Supervision   

 Transition    
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3. S7-GRAPH  

3.1. S7  

STEP7 S7-GRAPH STEP7 S7-GRAPH 

S7-GRAPH FB FB

, OB1  

 

 

3-1: S7  

3.2.  

3.2.1. S7-GRAPH  

STEP7 Sourc GRAPH Source,

 

CALL FB 2, DB2 
       
INIT_SQ:=M0.0 
 

GRAPH
 
 

OB/FB/FC 

GRAPH FB  GRAPH

DB 

DB

 

FB
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3-2: S7-GRAPH  

Block GRAPH FB

 

GRAPH source  

 

3-3:S7-GRAPH  

1.  

2.  
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3.  

4.  

5.  

3.2.2.  

 

 

 

 

 LAD/FBD LAD/FBD  

3.2.3.  

S7-GRAPH  

 

 

3-4:S7-GRAPH  

Interlock  

Interlock  

 Interlock S7-GRAPH

Interlock  

 Interlock  

o  

o  event L1  

Interlock 32 LAD/FBD “C”

Interlock  
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90 Interlock

 

 

3-5:  

Supervision  

Supervision  

 Supervision  V1 

 Si.U  

 Supervision

 

Supervision 32 LAD/FBD “V”

Supervision  

3.2.4.  

Graphic  

90  

90  
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3-6: Graphic  

Permanent instructions

 Insert New Element->Permanent Instruction Condition Call

S7-GRAPH FB

 

Permanent instructions  

 LAD/FBD  AND, OR, NETWORK 32  

 CALL  

Permanent instructions LAD/FBD FB,FC,

CALL  

 

Permanent 

instructions 

Permanent 

instructions 
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3-7: Permanent instructions  

Sequencer  

S7-GRAPH FB Sequencer( ) 

Sequencer  

 

3-8: Sequencer  

CALL  FC, FB  

LAD

 
 

山东科新教育科技发展有限公司

山
东
科
新
教
育



Variables  

S7-GRAPH FB Variables  

 

3-9: Variables  

3.2.5.  

 

 

CPU  

3.2.6. S7-GRAPH FB Source  

STEP7 S7-GRAPH  

 S7-GRAPH FB Block Insert New Object->Function 

Block->Created in Language GRAPH 

 S7-GRAPH Source Source Insert New Object->

GRAPH Source 

S7-GRAPH FB File->Generate Source File S7-GRAPH

Source S7-GRAPH Source File->Compile S7-GRAPH

FB  

S7-GRAPH FB

S7-GRAPH Source FB

S7-GRAPH Source

Source  
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4.  

S7-GRAPH FB  

 S7-GRAPH FB FB  

 S7-GRAPH FB FB

 

 S7-GRAPH FB Permanent instructions

Permanent instructions 

4.1.  

S7-GRAPH  

1.  

  

  

action active

active  

2.  

 active disturbaces  

 transition  

3.  

4.  

 jump FB

 

  

 

Step  

S7-GRAPH

 

Active Step  

 

 

  

 initial step  
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 event-dependent action  

4.2.  

 

4-1:  

 

1. S7-GRAPH FB  

2. S7-GRAPH FB  

3. S7-GRAPH FB  

4.3.  

 

 Step + Transition  

S7-GRAPH FB 

 

S7-GRAPH FB

FB  INIT_SQ=1  

 Jump  

 Open Alternative Branch  

 Close Alternative Branch  

 Open Simultaneous Branch  
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 Close Simultaneous Branch  

 Branch Stop  

 Insert Sequencer  

 

4-2:  

4.4.  

4.4.1.  
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4-3:  

 Object Properties,  

 

4-4:  

4.4.2. action  
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action S7-GRAPH FB

action  

 

4-5:  

 

 

 

 

4-6:  
 

4.4.3. action  

 

  

o interlock  

  

o interlock  

o  

  

4.4.4.  

 

4.4.5.  

action S7-GRAPH LAD
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4.5. S7-GRAPH  

S7-GRAPH FB PLC

 

 

Si.T i  

Si.U i  

Si.X  i  

Transi.TT  i  

4-1 S7-GRAPH  

S7-GRAPH  

 

4-7: S7-GRAPH  

4.6. S7-GRAPH FB  

S7-GRAPH FB

 

S7-GRAPH  Options->Block Settings... FB  

3  

3  
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4-8: S7-GRAPH FB  

4.6.1. S7-GRAPH FB   

S7-GRAPH FB 4  

1. Minimum FB SQ_INIT 

 

2. Standard FB

 

3.  Maximum (S7-GRAPH => V4.x) FB

 

4. User-defined (S7-GRAPH => V5.x) 

 

FB  
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FB  

) 

 

) 

  

(S7-GRAPH ) 
 

ACK_EF MOP.ACK "Acknowledge"  

INIT_SQ MOP.INIT "Initialize"  ( ) 

OFF_SQ MOP.OFF "Disable"  

SW_AUTO MOP.AUTO "Automatic (Auto)"  

SW_MAN MOP.MAN "Manual mode (MAN)"  

SW_TAP MOP.TAP "Inching mode 

(TAP)" 

 

SW_TOP MOP.TOP "Automatic or 

switch to next 

(TOP)" 

 

S_SEL - "Step number" 

S_ON / S_OFF S_NO  

S_ON - "Activate"  

S_OFF - "Deactivate"  

T_PUSH MOP.T_PUSH "Continue" 

 

SQ_FLAGS.ERROR - "Error display: 

Interlock" 

” 

SQ_FLAGS.FAULT - "Error display: 

Supervision 

” 

EN_SSKIP MOP.SSKIP "Skip steps"  

EN_ACKREQ MOP.ACKREQ "Acknowledge 

errors" 

 

HALT_SQ MOP.HALT "Stop seqencer"  

HALT_TM MOP.TMS_HALT "Stop timers" 

 

- MOP.IL_PERM "Always process 

interlocks" 

” 

- MOP.T_PERM "Always 

processtransitions" 

” 

ZERO_OP MOP.OPS_ZERO "Actions active" N, D, L

CALL  

EN_IL MOP.SUP "Supervision 

active" 

 

EN_SV MOP.LOCK "Interlocks active"  

4-2 S7-GRAPH FB  

FB S7-GRAPH  
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4.6.2.  

Interface Description Executability

Memory minimized FC73  

1. Memory minimized  

2. Structure arrays 

 

3. Individual structures

 

4.6.3. Executability  

1. Full code S7-GRAPH FB FB

FC  

2. Standard FC required (>=V4.x) FC  S7-GRAPH  

FC (FC70, FC71, FC72, or FC73) S7-GRAPH FBs FC  

Executability  

 Full code Standard FC70 Standard FC71 Standard 

FC72 

Standard FC73 

  

 8200 7750 10700 

 

8150  

 

S7-GRAPH 

V5.1  

 

S7-GRAPH V5.1 

 

.U

 

4-3 S7-GRAPH  

4.6.4.  

1. Criteria analysis data in DB SIMATIC  ProTool/ProAgent

  

2. Skip steps  

山东科新教育科技发展有限公司

山
东
科
新
教
育



3. Acknowledge errors disturbance

"ACK_EF" FB  Minimum

 

4. Synchronization (as of V4.0) 4.0  

5. Permanent processing of all interlocks in manual operation

interlocks 

 

6. Lock operating mode selection (V5.x) 

 

7. Safe activation mode (as of V5.1) 

 

4.7. S7-GRAPH FB  

S7-GRAPH FB S7-GRAPH FB

 

  

 PLC  

 S7-GRAPH FB

 

 S7-GRAPH FB

 

S7-GRAPH FB  
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4-9: S7-GRAPH FB  

4.8.  

 

S7-GRAPH FB S7-GRAPH FB

S7-GRAPH 

FB S7-GRAPH S7-GRAPH 

 

FB FB 

 

山东科新教育科技发展有限公司

山
东
科
新
教
育



 

FB  S7-GRAPH FB  

 

minimum 

10 standrad/maximum 

user-define 

 G7T_0 16  

 Trans1, Trans2 *16  

 G7S_0 32  

 Step1, Step2)  *32  

 - - 

 - - 

4-4 S7-GRAPH FB  

FB  

 
 

    

 TV     BOOL 

 

yes 

 

no  

 

yes  no 

 TT     BOOL 

 

yes 

 

no  

 

yes  no 

 TS     BOOL 

 

yes 

 

no  

 

yes  no 

 CF_IV   CRIT_FLT   BOOL 

 

yes 

 

no  

 

yes  no 

 TNO     INT   no 

 

no  

 

yes  no 

 CRIT   

LAD/FBD

32  

 

DWORD 

 

yes 

 

no  

 

yes  no 

 

CRIT_OLD  

LAD/FBD

32  

 

DWORD 

 

yes 

 

no  

 

yes  no 

 

CRIT_FLT   CRIT  

 

DWORD 

 

yes 

 

no  

 

yes  no 

4-5 S7-GRAPH FB  

FB  

         

 S1      BOOL   yes   no    yes   no   

 L1    interlock     BOOL   yes   no    yes   no   

 V1    Supervision   BOOL   yes   no    yes   no   

 R1     BOOL   no    no    no    no   
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 A1       BOOL   yes   no    yes   no   

 S0      BOOL   yes   no    yes   no   

 L0    Interlock   BOOL   yes   no    yes   no   

 V0    Supervision    BOOL   yes   no    yes   no   

 X       BOOL   yes   no    yes   no   

 LA    Interlock   BOOL   yes   no    yes   no   

 VA    Supervision   BOOL   yes   no    yes   no   

 RA     BOOL   no    no    no    no   

 AA     BOOL   no    no    no    no   

 SS     BOOL   no    no    no    no   

 LS   interlock     BOOL   yes   no    yes   no   

 VS   supervision    BOOL   yes   no    yes   no   

 SNO      INT    no    no    yes   no   

 T     TIME   yes   no    yes   no   

 U     TIME   yes   no    yes   no   

 CRIT_LOC   

Interlock

LAD/FBD 32

  DWORD   yes   no    yes   no   

 CRIT_LOC_ 

ERR   

 interlock 

 CRIT_LOC     DWORD   yes   no    yes   no   

 CRIT_SUP   

Supervision LAD/FBD

32   DWORD   yes   no    yes   no   

 SM     BOOL   no    no    no    no   

 LP     BOOL   no    no    no    no   

 LN     BOOL   no    no    no    no   

 VP     BOOL   no    no    no    no   

 VN     BOOL   no    no    no    no   

 H_IL_ERR     BYTE   no    no    no    no   

 H_SV_FLT     BYTE   no    no    no    no   

 RESERVED     DWORD   no    no    no    no   

4-6 S7-GRAPH FB  

 

S7-GRAPH  

S7-GRAPH  

S7-GRAPH  

S7-GRAPH  

Step1.S1, Step1  

Step1.S0, Step1  
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5.  

Debug-Monitor

Debug-Control Sequencer  

 
5-1:  

 
Debug-Synchronization

 

/
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5-2:  

S7-

GRAPH  

 

S7-GRAPH

 

6. S7-GRAPH  

6.1.  

S7-GRAPH  
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6-1:  

 

A,B,C 

X , 

 

 A   Q1.0         

 B  Q1.1  

 C   Q1.2  

  Q1.3  

 D   Q1.4  

  I1.0  

  I1.1  

 

 

 

 

 A A A,  

 B B  

 

  “0”  

  

  “1”  

  C C  

 10  

  

 

 A 

 C 

 B 

D 

A B C 
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6-2:  

 

6.2. S7-GRAPH  

FB2

 

 

A 

A 

B 

B 

 

5  

 

=0 

C 

C 

 

10  

 

D 

 

 
 

 

 

 
 

 

 

5  

A 
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D 

C 
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1)  

 
6-3:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2)  

山东科新教育科技发展有限公司

山
东
科
新
教
育



 
6-4:  

 
 

3) 

 
6-5:  

 
 
 
 
 
 
 
 

4)  
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6-6:  
 
 
 
 
 
 
 
 
 
 

5) 

 

 

 

 

 

->Insert New Element->Action 
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6-7:      

6) 

 
6-8:  

 

 

 

 

 

7) 

 

A  

3  
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6-9:  

8) 6-7  

9) 5  

 
6-10:  

 

 

5  

1
0 4  

2
 0 6  

5  
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10) Options-Application Setting FB

 

 
6-11:  

 

 

11) OB1 FB2 

 
6-12: FB2 

 
 
 
 
 
 
 
 

12) FB2 

 

 

 

山东科新教育科技发展有限公司

山
东
科
新
教
育



 
6-13: FB2 

 

 

13) “1”  

 
6-14: FB2 

 

 

 

 

 

 

14) Addresses  
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6-15:  

15) Debug-Control Sequencer  

 
6-16:  

90  
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S7-GRAPH  

 

S7-GRAPH

S7-GRAPH

 S7-GRAPH  

 
 

 

 

 

  

7. S7-GRAPH  

7.1.  

7.1.1.  

 100  

 S7 CPU  S7-300 CPU (CPU318 

) 100  CPU318  S7-400 

 200   

 

  S7-GRAPH  "Optionss > Application Settings... >  General" 

 "maximum number of status jobs used" 

CPU   

  CPU  (  CPU318  CPU400)  

  

7.1.2.  

? 

S7-GRAPH
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  Step 1   

  

 SIMATIC  CPU  S7-GRAPH 

 DB CPU    

S7-GRAPH  "Optionss > Application Settings... > General> On 

Saving" Include instance DB, FB FB

 

 

7-1:  

7.1.3.  

 S7-GRAPH FB  

“Interface Descriptio” “Download to PLC”

“Options > Block Settings > Compile/Save” “Download to PLC”

 S7-GRAPH FB  PLC

 

7.1.4.  

“OFF_SQ” TRUE “INIT_SQ”  
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“OFF_SQ” “INIT_SQ”

TRUE FALSE

“SW_MAN”

“SW_TOP”  

 

“OFF_SQ”  

“INIT_SQ”  

“SW_MAN”  

“SW_TOP”  

7.1.5. S7-GRAPH  

S7-GRAPH  CPU ? 

 S7-GRAPH 

 FC70 FC71 FC72  

FC73 S7-GRAPH  S7-GRAPH 

 5000 

S7-GRAPH FB S7-GRAPH

 

 S7-GRAPH FB  S7-GRAPH DB   

 FB  150  + n * 16   

 DB  236  + n * 26  

  

 20 

  

“ Full  Code ”  

 S7-GRAPH FB MC7    

 FB 4900 + 130  +   
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 DB 270 + 70  + 

  

 

 FB 4,900 + 20 x 130 = 7,500   

 DB 270 + 20 x 70 = 1,670  

 ”  S7-GRAPH  V4.0  

  

 FB 150  + 20 x 16  = 470   

 DB 236  + 20 x 26  = 756  

 FC70 FC71 FC72  FC73  FC71  FB7  

 FC73  S7-GRAPH FB CPU   

 8150  FC73  

 7750  FC71  

7.1.6.  

 

 S5  S2  S3  S2  S3 

S5  S5   

 S2  S5  S2  S3  S5

 T3  S5  

T3  S4       
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7-2:  

 S2  S3  S5  S5 

“U”  S5  4s “ACK_EF” 

 M0.2   

“SiT” “

SiU”  S7-GRAPH  V5.2 “

Options > Application Settings... > Editor Tab”   

 

7-3:  
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7.1.7.  

(“STEPi.U”)  

(“STEPi.U”) “Compile / Save”

FC73 FC72 FC73 S7-GRAPH FB

“U”   

Options > Block settings >Compile / Save>Executability

FC72 “Memory minimized” “Structure arrays” OK

S7-GRAPH FB CPU   

7.2.  

7.2.1.  

 

S7-GRAPH FB

  

 G7S[1].X    

 G7S[1].SNO   

 1   

A  FB2.G7S [1].X 

=  M0.0   //M0.0  1  

L  FB2.G7S [1].SNO 

T  MW2   //MW2  

"Options > Block settings > Compile/Save “Structure arrays”

  

 :G7S  

 ) * 32 
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7-4: “Structure arrays”  

7.2.2.  

 

“TV”“TT” “TS”   

 TV BOOL)  

 TT BOOL)  

 TS BOOL)  

S7-GRAPH FB STEP 7 (LAD/STL/FBD

  

 T002.TT 

  

 G7T [2].TT 

 

 

7.2.3.  

 

 

1. (ARRAY) “SAX”

SFC 20“BLKMOV ”

 

CALL "BLKMOV" // DB2 SAX field _SAX ARRAY[1..50] 
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SRCBLK :="MY_DB1".SAX 

RET_VAL:=MW66 

DSTBLK :="MY_DB2".Save_SAX 

 

2. deactive

SFC 20 “SONX”   

CALL "BLKMOV" //  

SRCBLK: ="MY_DB2".Save_SAX 

RET_VAL:=MW66 

DSTBLK: ="MY_DB1".SONX 

3. “OFF_SQ”

  

 

 

“SAX” “SONX” “SAX”

 

 

7.2.4.  

Supervision Disturbance  

S7-GRAPH Supervision Disturbance

Supervision=TRUE “ACK_EF”

“ACK_EF”   

S7-GRAPH  “Options > Block Settings> Compile / Save>Sequencer Properties”

 “Acknowledge errors”   
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7-5:  “Acknowledge errors”  

“FB Parameters” “Minimum”

“FB Parameters” “Standard”“Maximum” “User-defined” 

Supervision
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7-6: Supervision  

 

M1.7=1  M1.0 M1.2 “1”

Supervision Disturbance “Acknowledge 

errors”  

7.2.5. S7-GRAPH  

S7-GRAPH  

S7-GRAPH FB DB FB

“Compile / Save” “Options > Block Settings” “FB Parameters”

“User-defined (V5.x)”   

S7-GRAPH (FB, FC or OB1)

S7-GRAPH FB   

  

 S_NO   

 S_MORE S_NO   

 S_ACTIVE   

 SEF_DISP   

 ERROR   

 FAULT  

  

 DISP_SEF  
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S7-GRAPH STEP Structure  

7.2.6.  

 

S7-GRAPH Supervision  

 Supervision  V1 

 Si.U  

 Supervision

 

  

 

7-7:  

 

 M1.2   

 M1.3  
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7.2.7. “L0 S”  

“L0 S”  

 S7-GRAPH “L0 S”

 1 1

  

S7-GRAPH 

“L0 S” 

 

7.2.8.  

 

 “View > Sequencer”

“Insert New Element > Alternative Branch > Open”  
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7-8:  

“Edit > Paste”   

  

7-9:  

7.2.9. OB1 S7-GRAPH FB  

OB1 S7-GRAPH FB  

OFF_SQ FB “INIT_SQ” “OFF_SQ”

  

“Options > Block settings... > Compile/Save > FB Parameters “Standard” “

Maximum” “User-defined”   

3 

“Cut” 

Paste

3 
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S7-GRAPH FB M0.0  “OFF_SQ”

“OFF_SQ”   

 

7-10:  

Supervision  

1( ) M10.3 M10.3 “False”

“Acknowledge errors”

FB “ACK_EF”   

 

7-11: Supervision  
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7.2.10.  

? 

S7-GRAPH BCD BCD (3

BCD) : C#000 C#999  

7.2.11.  

? 

S7-GRAPH 

 

7.2.12. : S7-GRAPH  

S7-GRAPH  

STEP7 STL S7-GRAPH

S7-GRAPH STL  

 

1. S7-GRAPH FB S7-GRAPH FB  

 S7-GRAPH FB “File > Generate Source File...” S7-GRAPH

  

 “Source_FB”   

 OK S7-GRAPH S7-GRAPH FB  

2. STL FB 

 Windows “Start > SIMATIC> STEP 7 > LAD STL FBD-

Programming S7 Blocks” LAD/STL/FBD   

 LAD/STL/FBD “File > Open” STEP 7 S7-GRAPH

FB51)   

 “File > Save”

(S7-GRAPH) “Yes” S7-

GRAPH STL  

3. STL  

 LAD/STL/FBD “File > Generate Source...” STL   

 “Protect_FB”   

 STL FB51) “Blocks 

Selected”   
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 OK STL LAD/STL/FBD  

4. “Sources”   

 STL (Protect_FB)  

 S7-GRAPH (Source_FB)  

5. FB 

 STL  “Protect_FB” “TITLE”

KNOW_HOW_PROTECT  

 “File > Save" and "File > Compile” STL FB51  
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